Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 16, 2026 - 19:30 EDT
Scheduled
Maintenance in Regions QC (Quebec) / Scheduled Maintenance for 5C Cloud Platform
Dear Customers,
A maintenance window in the Quebec region will take place on: September 16, 2026 from 19:30 EDT to 20:00 EDT.
Impact: We expect a network interruption for a few minutes time, and for the duration of the maintenance, customers will be unable to stop, start, or create VMs, networks, or templates, or volumes.
This update will improve performance, stability, and security throughout our environment.
Thank you for your attention and cooperation as we continue to enhance our platform. If you have any questions or concerns, please do not hesitate to contact us.
Thank you,
The 5C Cloud Team
Posted Sep 15, 2026 - 08:52 EDT
This scheduled maintenance affected: Customer resources - Quebec Region (Network, Virtual Instances, Storage).